Welcome
Welcome to kangertech

You are currently viewing our boards as a guest, which gives you limited access to view most discussions and access our other features. By joining our free community, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content, and access many other special features. In addition, registered members also see less advertisements. Registration is fast, simple, and absolutely free, so please, join our community today!

kbox mod

Re: kbox mod

Postby kangertech » Sat May 30, 2015 9:48 am

I am sorry for your case.
I suggest you change your cell ,then have a try.
If this can not help ,you should take your kbox to your dealer for heping.
kangertech
Site Admin
 
Posts: 2263
Joined: Mon Nov 17, 2014 2:28 pm

Re: kbox mod

Postby RangerVic006 » Wed Jan 06, 2016 8:51 am

Hi. I bought the KangerTech KBox 8-40W (Variable Wattage) about 4 months ago. About a month or so into using it, it began to fail when attempting to fire it up. I bought two batteries the same day I purchased the device and tried both in case one was faulty. The same issue continued to happen. I took the device to where I purchased it and the owner took a look, tried a different clearomizers, batteries, and new coils. He stopped short of taking it completely apart before saying that he didn't know what could be causing the problem. He suggested I get in touch with the company to see if you guys have any advice. It works sporadically but I have to press up on the battery cover and pull the clearomizer towards me when inhaling. This works about once out of every five times I try it, but it is extremely frustrating, especially for the amount of money I spent on it. Could you please advise me on what I could do and what alternative options I have? I value your products but I also see that this isn't the first time this has happened with this specific model. Please help. Thank you for your time.
RangerVic006
 
Posts: 1
Joined: Wed Jan 06, 2016 8:11 am

Re: kbox mod

Postby kangertech » Wed Jan 06, 2016 9:16 am

Please come back to your dealer for help,if it is manufacturing issue,they can send it back to their distributor and finally back to kanger to verify.
kangertech
Site Admin
 
Posts: 2263
Joined: Mon Nov 17, 2014 2:28 pm

Re: kbox mod

Postby TDF » Thu Jan 07, 2016 12:04 am

I ran into a similar issues recently -- I've owned my KBOX mini + subtank (kit) for a few months now. I recently picked up a new tank (Bellus RDTA) and was using it successfully on the KBOX mini up until last night. I got maybe a couple days usage with this tank without issue (and I was able to get the KBOX to fire 0.3ohm coil which I believe the docs say is the lowest it'll fire) until I rebuilt my tank to 0.25 ohm and it wouldn't fire (of course) -- oddly enough, it WAS firing the 0.25ohm coil for over a day without issue. Now the battery light blinks 10-12 times when trying to fire it.

I put my original black subtank mini back on, works fine. Couple of things I noticed:

1 - no spring loaded 510 pin. Really? I read something on reddit about retro-fitting a spring-loaded 510 pin into the KBOX but I'm not going to try, it's out of my league.

2 - The insulating rubber grommet around the 510 pin is a bad design idea. Taking tank(s) on and off the KBOX will eventually wear this part out. I saw a cool post on Reddit (again) where a guy screwed on a 22mm finned heatsink and then screws his tanks into that. This method should keep this grommet intact and the heatsink has an adjustable center 510 center pin.

Just interesting (to me) that the original KBOX (the silver one with LEDs on it) seems to be better designed/built than one of Kanger's flagship devices.

I've been a Kanger person since I started vaping a year ago but I have to say, guys, you need to step up your game to compete out there:

1 - Any of your mods SHOULD have a spring-loaded center 510 pin and SHOULD be better isolated from the frame than a simple rubber grommet that wears out with usage. Since it's a "non replaceable" part, this looks to be designed obsolescence. Considering I paid almost $100 for the kit, I'd expect better quality.

2 - Take cues from companies like UD and their Bellus tank. I was able to fire this tank on my KBOX mini @ 50watts and it was absolutely awesome. I can't fire any subtank I own (original+kit, v1+v2 rba) at anything over 25-30watts because it can't wick fast enough. The best thing about this other than the vape was the form factor, easily portable whereas my RX200 is a lot beefier and not exactly a mobile vape mod (imo)

Sorry Kanger, I think you're getting a touch out of scope here. The current Kanger devices seem to be built for fashion rather than function. I find myself leaning more towards competing companies because their designs and builds seem to be the way Kangertech USED to be.
TDF
 
Posts: 3
Joined: Tue Dec 29, 2015 1:38 am

Re: kbox mod

Postby Soundguy » Thu Nov 10, 2016 5:37 am

Mine didn't fire straight out of the box! Three flashes with each push, no power. Battery is fresh and charged, tank is Atty Cubed, and coil is 24-gauge titanium coil wire. I metered the coil and it's over .4 ohms resistance, it's .7.
I emailed the dude above but figured I'd post here also.
Soundguy
 
Posts: 2
Joined: Thu Nov 10, 2016 5:34 am

Re: kbox mod

Postby kangertech » Thu Nov 10, 2016 8:54 am

Please change to use NiCr coil and test it.
kangertech
Site Admin
 
Posts: 2263
Joined: Mon Nov 17, 2014 2:28 pm

Re: kbox mod

Postby Soundguy » Sun Dec 04, 2016 2:07 am

The Kbox mod works perfectly, I love it. My problems were my fault! Firstly, the coil was below .4 ohms resistence, and secondly the vape store sold me fake batts! I never thought that would be the case, but it was! Thanks Kanger for being so responsive!
Soundguy
 
Posts: 2
Joined: Thu Nov 10, 2016 5:34 am

Re: kbox mod

Postby smokey88 » Sat Dec 31, 2016 11:05 pm

My kbox keeps flashing sometimes 4 times but mainly 17 times I have new batteries and will discharge correctly like the other comments you made in previous posts I also have a new coil in my tank what else can I try
smokey88
 
Posts: 1
Joined: Sat Dec 31, 2016 10:59 pm

Re: kbox mod

Postby ConcreteKANE » Tue Jan 03, 2017 2:25 am

Hello their I been having my kbox 8-40 watt mod for about a year it was giving to me as a gift. Use to work now it doesn't flashes 3-4 times and stays on also changed to another rda and doesn't fire, switched also to a rta and doesn't fire either, all the times it flashes 4-5 times. I changed out batteries as well. I took the 510 connection apart I cleaned it up and even put a new insulator in their. But still giving me problems. How can I fix this.
ConcreteKANE
 
Posts: 1
Joined: Tue Jan 03, 2017 2:09 am

Re: kbox mod

Postby kangertech » Tue Jan 03, 2017 8:38 am

smokey88 wrote:My kbox keeps flashing sometimes 4 times but mainly 17 times I have new batteries and will discharge correctly like the other comments you made in previous posts I also have a new coil in my tank what else can I try

The kbox will flashing 3 or 15 times not 4 or 17times.Flashing 15 times means the battery beed to be charged,please check yours.You can change a new battery test it ,discharge over 25A.
kangertech
Site Admin
 
Posts: 2263
Joined: Mon Nov 17, 2014 2:28 pm

Previous

Return to Battery

Who is online

Users browsing this forum: No registered users and 1 guest

cron
suspicion-preferred